How To Install-Run Siri On iOS 6 Running iPhone 4 – iPod Touch 4th Gen

Chiphazard : Installed the latest iOS 6 on your iPhone 4 device?, can’t get rid of Apple maps but atleast want to run Siri on it? Well you’re in luck as you can run Apple’s voice assistant on your A4 iOS device, provided that your iPhone 4, iPod Touch (4th Gen) device is jailbroken (tethered).

Read Full Story >>
The story is too old to be commented.
Crazyglues1474d ago (Edited 1474d ago )

Wait there is a jailbreak for iOS 6, what rock have I been living under... ..

So glad I woke up to this site this morning..-

"iPhone it looks like we have some installing to do.."